Modèles de flux de travail invisibles (?!)

Je viens de subir un cas assez étonnant, survenant sur une instance de collection de site uniquement (et affectant donc le site racine et l’ensemble de ses sous-sites). Aucune idée de ce qui a pu générer cela … mais voici néanmoins un petit état des lieux de ma démarche.

Etat des lieux :

  • L’ensemble de fonctionnalités de collection de site faisant référence aux flux de travail étaient activés (Flux de travail, Flux de travail à trois, états, Flux de travail approbation de destruction, Flux de travail d’approbation de publication, Flux de travail SharePoint 2007, Options Web Analytics avancées).
  • /_layouts/wrkmng.aspx me confirme bien que l’ensemble des flux de travail sont « Actifs » (Administration de la collection de sites > Flux de travail).

Deux états de faits :

  • Lorsque j’essayais d’associer un flux de travail (via un compte administrateur de la collection de site) sur une bibliothèque de documents je n’ai à ma disposition que les flux de travail trois états et l’approbation de destruction de disponible. J’ai difficilement trouvé une source à mon soucis, mais pas de solution à l’horizon : Only Deposition Workflow is avaliable in SharePoint 2010
  • Lorsque je m’amusais à ouvrir le site racine via SPD je n’ai aucun « Globaly Reusable Workflow / Flux de travail réutilisable globalement » de disponible.

J’ai pu reproduire ce mode de fonctionnement (sauf côté SPD) en désactivant les flux de travail définis par l’utilisateur (Centrale d’administration > Paramètres généraux de l’application web > Flux de travail). Comme indiqué en introduction, seule une collection de sites était touchée par ces soucis.

J’ai, une énième fois, désactivé l’ensemble des fonctionnalités de collections de sites liées aux flux de travail (voir ci-dessus). A la réactivation de n’importe laquelle des fonctionnalités suscitée,  j’ai eu le droit au message d’erreur suivant :

Une liste, une enquête, un forum de discussion ou une bibliothèque de documents avec le titre spécifié existe déjà dans ce site Web. Veuillez choisir un autre titre.

Il était clair que l’activation de ces fonctionnalités étaient interrompus par un processus de création. L’ordre de désactivation a t’il généré cette erreur ? aucune idée. Néanmoins, en fouillant un peu ici et là, j’ai rapidement pu retrouver mes petits. A priori, tout se trouve concentré au niveau de la bibliothèque _catalogs/wfpub. Via SPD j’ai rapidement pu constater que, même si celui-ci existait, il n’était pas considéré comme étant une bibliothèque de documents SharePoint (et son icône associé). Une fois ce dernier renommé (en wfpub_old), les fonctionnalités ont de nouveau pu être redéployées. Par la même, les flux de travail étaient à nouveau activable.

Rien ne me permet d’affirmer la cause de ces dysfonctionnements. Je n’ai pas non plus poussé le vice à chercher/trouver les causes de tout cela, mais à force d’habitude, une certaine connaissance des méandres de SharePoint permet de s’affranchir de problèmes qui peuvent, à priori, sembler bloquants voir difficilement surmontables.

Timer Job Product Version Job : Erreurs 10016, 1015

Dans la série « Les anomalies redondantes » …

Chaque jour, à 0:45, s’exécute un Timer Job intitulé « Product Version Job ». Ou en français dans le texte « Travail de version de produit ». Comme l’indique l’article TechNet faisant référence aux travaux du minuteur, ce job vérifie l’état d’installation de l’ordinateur et ajoute ces données à la base de données. Soit …

Certaines manipulations permettant de résoudre les différentes remontées d’anomalies liées à ce job existent. Mais comme l’indique Tristan Watkins, en absence de réponse claire et précise sur le sujet, il est préférable de vivre avec ces événements et de les superviser plutôt que de s’affranchir des informations capitales qu’ils peuvent délivrer.

Références :